N’utilisez pas Hudson 1.344 !!

Je vous aurai prévenu :-)
J’ai découvert un bug bloquant (http://issues.hudson-ci.org/browse/HUDSON-5536) qui corrompt les données locales. Ainsi même un retour en arrière sur la version d’Hudson ne vous corrige pas le problème. La correction manuelle à faire sur les fichiers Hudson est décrite dans l’issue Jira si par malchance vous avez déjà fait l’upgrade et que comme moi vous vous retrouvez avec tous vos builds KO.
L’équipe va probablement sortir une version 1.345 en urgence dans les heures à venir.
Merci à Andrew Bayer (@abayer sur twitter) pour son coup de main.

GD Star Rating
loading...
GD Star Rating
loading...

6 thoughts on “N’utilisez pas Hudson 1.344 !!”

  1. Chez moi, pas de problème de build, juste l’update center HS.

    Après un retour en 1.343, j’ai nettoyé le repertoire de travail de tomcat et supprimé le repertoire “updates” (qui contient certains js) de mon install de Hudson et c’est tout bon.

    GD Star Rating
    loading...
    GD Star Rating
    loading...
    1. En fait la nouvelle version télécharge des fichiers qu’elle n’est pas capable de lire. C’est ballot. Dans mon cas, cela a planté corrompu les listes de référence des versions de Maven et JDK. Mes builds qui utilisent donc un Maven installé par Hudson étaient donc tous KO.

      GD Star Rating
      loading...
      GD Star Rating
      loading...
  2. Merci de prévenir !
    Cependant, malgré la présence d’un bug bloquant, Hudson continue à me proposer la mise-à-jour dans l’interface d’administration… faudrait peut-être qu’ils enlèvent le build foireux du site web de Hudson…

    GD Star Rating
    loading...
    GD Star Rating
    loading...

Leave a Reply

Your email address will not be published. Required fields are marked *

*

You may use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>