Tous les articles par Arnaud Héritier

Utiliser différentes versions de Java sous Leopard

Problématique

Comme beaucoup de développeurs Java pour m’assurer que mon code est bien compatible au niveau des APIs avec la cible recherchée (1.4, 1.5, 1.6, …) je dois utiliser la version de Java en question pour construire et tester mon projet (Par exemple Maven 2.0.x et ses plugins doivent toujours êtres compatibles avec Java 1.4).

Apple fournit les différentes versions de Java dont vous avez besoin. Dans mon cas j’ai récupéré la totale c’est à dire Java SE 6 (1.6.0_07), J2SE 5.0 (1.5.0_16), et J2SE 1.4.2 (1.4.2_18).

Maintenant comment passer d’une version à l’autre ? Il existe pour cela plusieurs solutions. Continuer la lecture de Utiliser différentes versions de Java sous Leopard

GD Star Rating
loading...
GD Star Rating
loading...